Export and import page hierarchy using Administration Portlets

In addition to the command line interface, Portal also provides couple of portlets that you can use to work with the xmlaccess.


  1. Manage Pages Portlet: You can use the Manage pages portlet to export either a page or page hierarchy. In the Manage pages portlet click on Export button next to the portlet or label that you want to export. It will ask you if you want to export only that page or the hierarchy below it. Select appropriate option and it will ask you to download the result xmlaccess


  2. You can use Import XML portlet to execute an xmlaccess script on the target server. Just go to the Import XML portlet select the xmlaccess script that you want to execute.It will display the result on the next page. It does not allow to download the result xml file.


8 comments:

Gulshan Panjwani said...

Hi Sunil,
Where does it save...as it's not asking for location...

Anonymous said...

It will launch another window then ask you for a save location. The window is probably being blocked by a pop-up blockers so check for a message in your browser and allow the pop-up.

adiksw said...

Can I import the page on the same Portal as a new page? I would like to make a copy of the page.

Vasu said...

Don't do that. Create a new page manually and assign a unique value for the page.

Since each page should have a unique name for identification for scripts.

Unknown said...

Hi Sunil, I have imported a new page using import xml portlet, and it showed a sucees message. But when I tried to acces that page from navigation its showing error messages "Invalid configuration found". Did i miss any step here.

Manas Jena said...

Hi Sunil, I have imported a new page using import xml portlet, and it showed a sucees message. But when I tried to acces that page from navigation its showing error messages "Invalid configuration found". Did i miss any step here.

Manas Jena said...

Hi Sunil, I have imported a new page using import xml portlet, and it showed a sucees message. But when I tried to acces that page from navigation its showing error messages "Invalid configuration found". Did i miss any step here.

Manas Jena said...
This comment has been removed by the author.